Showing results for 
Search instead for 
Did you mean: 

Unable to enter player name

Skylanders Battlecast Forum

I started playing Skylanders Battlecast yesterday, but I've been unable to create a player name.


When I tap on the friends list button, it pops up a window to enter my player name.  I enter my name (seven letters, no numbers or special characters), then tap on Confirm.  The window goes away, then comes right back.  When I tap on Confirm, it looks like the Cancel button is also highlighted.


If I go to play a versus game, it will also pop up the window to create my name.  I enter my name, tap confirm, then the game loads.  However, in the game where my name should be displayed is blank.


I am playing the game on a Nexus 6P with Android version 7.1.1.  My friend is on the same phone, and is having the same issue.


I have tried Force Stopping the game, restarting my phone, and uninstall/reinstall the game.  None of that has worked, and I'm out of ideas.


Is there any way to fix this, so that I can play the game with my friend?

Likes: 1
Posts: 1
Registered: ‎04-03-2017

We have same issue

Likes: 1
Posts: 1
Registered: ‎31-03-2017

Omg same and no one from the support team seems to be helping

Likes: 0
Posts: 1
Registered: ‎05-06-2017
Visit us for the latest news, game information, screenshots, downloads and links. GO TO BLOGS