Lag Problem?

Call of Duty Ghosts Support Forum

Lag Problem?

Hopefully i am in the right forum. To anyone out there who can help, i would greatly appreciate it.

When i first bought Ghosts it ran like a dream. I had no issues with it in any way. About a week or two ago i started experiencing some serious lag issues, in multiplayer. I tried searching other sites for any type of help, but all the research i did was either too vague and non-helpful, or it did not pertain to my problem specifically. This lag issue has only recently become a problem, and for quite a while i did not have any trouble with lag at all. It has become so bad now, that multiplayer is pretty much unplayable. Is there anyone out there that knows how to fix this, or has some suggestions?

I have a higher end Netgear router thats made for gaming. My signal on my PS4 is NAT Type 2, and the connection speed of upload and download varies. I have 100% signal strength. I just cant figure out why the lag started, and how to fix it. Ive already tried restarting and rebooting everything from the router to the console. I would be very grateful for any help anyone can provide.

Level 3
Likes: 32
Posts: 38
Registered: ‎13-03-2014
19 REPLIES

Re: Lag Problem?

in reply to Omerta_Phoenix

Did you gave your console a static ip and forwarded the proper ports to it?

Wired or wireless?

Level 19
Likes: 115
Posts: 763
Registered: ‎21-06-2011

Re: Lag Problem?

in reply to Featherman84

i use wifi/wireless. and i have no idea how to forward it to the proper ports

Level 3
Likes: 32
Posts: 38
Registered: ‎13-03-2014

Re: Lag Problem?

in reply to Omerta_Phoenix

1.Go for a wired connection.

2.Set your ipadress on your ps4 manually(to make it static), log in on your router and  add ports for incoming and outgoing traffic, in the forwarding section of your router settings ,the ipadress you add to each forwarding row is the one you gave to your ps4.

3.Ports for this game and psn can be found on portforward.com(Also "How to" guides can be found here).

Level 19
Likes: 115
Posts: 763
Registered: ‎21-06-2011

Re: Lag Problem?

in reply to Omerta_Phoenix

Forwarding ports will not help you and is totally unnecessary.  Just make sure you have UPNP enabled.  Portforwarding is snake oil these days.

there is a lag issue with the game right now and nothing we can do about it but wait and see if it gets fixed.  As long as your NAT type is open you should be good.

creating static IPs for the devices on your network is always a good idea and if you are running a lot of devices you can configure QOS settings to prioritize your gaming packets.  Outside of that there isn't much you can do.

Level 4
Likes: 23
Posts: 66
Registered: ‎18-02-2014

Re: Lag Problem?

in reply to Greatgollymsmol

Greatgollymsmolly wrote:





there is a lag issue with the game right now and nothing we can do about it but wait and see if it gets fixed.  As long as your NAT type is open you should be good.




Lag issue with this game?

Don't you mean: "lag issue because my settings aren't alright."

Level 19
Likes: 115
Posts: 763
Registered: ‎21-06-2011

Re: Lag Problem?

in reply to Featherman84

is anyone else experiencing lag issues on the psn? ive heard players in game and in lobby complain  that they too are experiencing lag issues. but i dont have a head set so i cant efficiently communicate with them. are either of you experiencing lag issues with Ghosts as well?

Level 3
Likes: 32
Posts: 38
Registered: ‎13-03-2014

Re: Lag Problem?

in reply to Featherman84

Uhhh a lot of people are having issues after the last "patch" they did last week which is right around the time he said it started.  I for one am running wired connection port forwarded.  And yet after the last patch I have been dying extremely fast, I will be watching a door sound whoring someone shoot them as they walk through the door they keep walking forward and I drop dead without seeing them even look at me.  Yet I get about 6-7 hitmarkers in the process.  The game is having major issues even people that don't complain on the forums are saying they have had problems.

Level 7
Likes: 69
Posts: 180
Registered: ‎25-02-2014

Re: Lag Problem?

in reply to LT--SHiNySiDeZ-

Shiny now that you mention it, it was right after i downloaded that new update that i started having the problems. i had to recap a little, but i remember now that the game ran perfectly, until that downloaded update. and thats another thing ive been noticing too, that you mentioned. when i use SMGs i almost NEVER aim down the sights. i pretty much always hip fire, using steady aim perk of course. i used to get 15 kills average on TDM. but this past week, not only have i been killed by guys after i shot them first, but also ive been killed by guys that shot first, and they some how had enough time while being shot, to aim down the sights and shoot and kill me. there was a couple of times even the kill cam showed me getting the first off and hitting them. i got so exhausted from that crap i had to go play AC Black Flag to take a break

Level 3
Likes: 32
Posts: 38
Registered: ‎13-03-2014

Re: Lag Problem?

in reply to Omerta_Phoenix

There are also a lot of people who benefit of the latest patch.

People who don't have an issue don't come informing on these forums as much as people who do have issues with the game.

Level 19
Likes: 115
Posts: 763
Registered: ‎21-06-2011

Studios