7 Replies Latest reply: Oct 25, 2013 5:06 AM by LifeSong1 RSS

Problems Registering for a Clan? Help.

DaNamesBond22

This may seem simple, but I've been having trouble with it. I made this Call of Duty Account and everything. Then it says you need to link you PSN Account on here in order to register for a clan. I've already done that though and confirmed the email.

 

It keeps saying I need to link the account before I can register though. Anyone know what the problem might be? Thanks

  • Re: Problems Registering for a Clan? Help.
    Bardygrub

    HHave you linked your psn to the new ghosts elite or the old elite?

    • Re: Problems Registering for a Clan? Help.
      DaNamesBond22

      I did it through the profile.callofduty.com/cod site.

       

      3 options at the top of the page include Overview, Community Activity + Settings, Preferences.

       

      Then it has my profile/personal information on the page. In the console section at the bottom right, it says that I have linked my PSN account.

       

      I don't know if that clears it up or not.

      • Re: Problems Registering for a Clan? Help.
        Bardygrub

        Yep that's it! So it says that you have linked your acc and has a tick? Before you did this were you in a clan?

        also, try hitting the settings button, top right hand cnr, to the left of find a player. Log out and log back in again.

        • Re: Problems Registering for a Clan? Help.
          Derparrific

          I'm having the same problem, only my account is linked to XBLA. I am currently in a clan (clan leader actually).  Do the old clans carry forward, or is this completely separate?  I created another account because of the problems I was having trying to get the Ghosts clan registered and when I looked up the name I am using for BO2 and want to use for Ghosts it said it was already reserved.  I've tried to do some moderate research on this, but due to time constraints I am in a bit of a rush.

           

          * Edit - So I was able to fix the problem.  I logged in using IE instead of Chrome and everything went smoothly.

          • Re: Problems Registering for a Clan? Help.
            TWJackDanielsTW

            I logged out and back in and it changed the screen completely for me and worked.

          • Re: Problems Registering for a Clan? Help.
            LifeSong1

            Derparrific wrote:

            Do the old clans carry forward, or is this completely separate? 

            The old clans do NOT carry forward. They are 2 separate entities with their own rosters.

             

            Derparrific wrote:

            I created another account because of the problems I was having trying to get the Ghosts clan registered and when I looked up the name I am using for BO2 and want to use for Ghosts it said it was already reserved.  I've tried to do some moderate research on this, but due to time constraints I am in a bit of a rush.

             

            The names are on a first come first serve basis and now that clans are cross platform, there are a lot of name conflicts due to someone on the other platform grabbing the name before you could. Read through this thread for full details on how the new clans are working: http://community.callofduty.com/thread/200777474

             

            Derparrific wrote:

            * Edit - So I was able to fix the problem.  I logged in using IE instead of Chrome and everything went smoothly.

            I guess there is a first time for everything. I avoid IE like the plague and am very shocked that it suddenly worked when you used IE. Either way...glad you got it working.

  • Re: Problems Registering for a Clan? Help.
    LifeSong1

    The suggestions others have made (verifying your PSN ID is linked in your profile, logging out and logging back in, etc) are the typical ones and I'm not sure what else there is to do in order to set it up. Try to make sure your profile is setup completely (don't need Xbox, Twitch, or YouTube) but most of the rest should be completed.  You may want to reach out to @ATVIAssist on Twitter and see if they can help you out if you continue to have the problem.